Draggable

Maycon free asked 2 years ago

Hi, i tried to install the draggable plugin in my project and it is presenting error in the compilation, can you help me?

app.modules

enter image description here

enter image description here

error compilation:

enter image description here

package.json

enter image description here


Arkadiusz Idzikowski staff commented 2 years ago

Which Angular, MDB Angular and Typescript versions do you use?


Maycon free commented 2 years ago

Angular: 8.3.22 MDB Angular: 8.10.0 Typescript: 3.5.3


Arkadiusz Idzikowski staff commented 2 years ago

Angular 8 requires Typescript >= 3.4.0 and < 3.5.0. You should also use v8.x.x of the Draggable plugin in this case.


Maycon free commented 2 years ago

instead of a downgrade, can I do a upgrade? I`m thinking in the last versions:

Angular: 10 MDB angular: 9.3.1 Typescript: last version


Arkadiusz Idzikowski staff commented 2 years ago

MDB Angular 9.x.x is compatible only with Angular 9.


Maycon free commented 2 years ago

thank you for the support, it worked


Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue
  • User: Free
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: 9.3.1
  • Device: any
  • Browser: any
  • OS: any
  • Provided sample code: No
  • Provided link: No