Topic: Accordion doesn't collapse since upgradint to 6.1.1

robsilva pro asked 4 years ago


Hi guys, The accordion stopped working since upgrade. See: https://screencast.com/t/obebZiRTSxzh Here's the behavior: https://screencast.com/t/dkgWL53dHA Here's my package.json   { "name": "hbsPoll", "version": "1.0.0", "license": "MIT", "scripts": { "ng": "ng", "start": "ng serve", "build": "ng build", "test": "ng test", "lint": "ng lint", "e2e": "ng e2e", "appVersion": "node appVersion.js" }, "private": true, "dependencies": { "@angular-redux/store": "^6.5.7", "@angular/animations": "^6.0.1", "@angular/common": "^6.0.1", "@angular/compiler": "^6.0.1", "@angular/compiler-cli": "^5.2.11", "@angular/core": "^6.0.1", "@angular/forms": "^6.0.1", "@angular/http": "^6.0.1", "@angular/platform-browser": "^6.0.1", "@angular/platform-browser-dynamic": "^6.0.1", "@angular/router": "^6.0.1", "chart.js": "^2.5.0", "classlist.js": "^1.1.20150312", "core-js": "^2.4.1", "easy-pie-chart": "^2.1.7", "font-awesome": "^4.7.0", "hammerjs": "^2.0.8", "intl": "^1.2.5", "jquery": "^3.2.1", "ng-drag-drop": "^4.0.1", "ng-uikit-pro-standard": "git+https://oauth2:XXXXXXXXXXXXXXXXXXX@git.mdbootstrap.com/mdb/angular/ng-uikit-pro-standard.git", "ng2-filter-pipe": "^0.1.10", "ngx-order-pipe": "^2.0.1", "redux": "^3.7.2", "redux-observable": "^0.18.0", "rxjs": "^6.2.0", "rxjs-compat": "^6.2.0", "screenfull": "^3.3.2", "underscore": "^1.8.3", "web-animations-js": "^2.3.1", "wowjs": "^1.1.3", "zone.js": "^0.8.14" }, "devDependencies": { "@angular-devkit/build-angular": "~0.6.5", "@angular/cli": "^6.0.1", "@types/jasmine": "2.8.6", "@types/jquery": "^3.3.0", "@types/node": "~9.4.0", "@types/underscore": "^1.8.1", "codelyzer": "~4.1.0", "jasmine-core": "~2.9.1", "jasmine-spec-reporter": "~4.2.1", "karma": "~2.0.0", "karma-chrome-launcher": "~2.2.0", "karma-cli": "~1.0.1", "karma-coverage-istanbul-reporter": "^1.4.1", "karma-jasmine": "~1.1.0", "karma-jasmine-html-reporter": "^0.2.2", "protractor": "^5.3.2", "ts-node": "~4.1.0", "tslint": "~5.9.1", "typescript": "~2.7.2" } }  

Damian Gemza staff answered 4 years ago


Dear robsilva, Could you please try to reproduce your error on fresh Angular project with only MDB Angular installed? I've tried to reproduce your case, but for me, everything is working fine. I'm using code from below:
<mdb-squeezebox [multiple]="true" aria-multiselectable="true">

<mdb-item [collapsed]="true">

<mdb-item-head> Item Title 1 </mdb-item-head>

<mdb-item-body> Item Body 1 </mdb-item-body>

</mdb-item>

<mdb-item [collapsed]="true">

<mdb-item-head> Item Title 2 </mdb-item-head>

<mdb-item-body> Item Body 2 </mdb-item-body>

</mdb-item>

<mdb-item [collapsed]="true">

<mdb-item-head> Item Title 3 </mdb-item-head>

<mdb-item-body> Item Body 3 </mdb-item-body>

</mdb-item>

</mdb-squeezebox>
Also could you try to remove jQuery from project? Maybe jQuery blocks it. Also does your console throws any errors? Best Regards, Damian

Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No
Tags