Angular 11

evieira357 pro asked a year ago

Hi guys, what`s the schedule to launch the mdb angular 11?


MDB Angular 11.0.0 was released yesterday:

https://mdbootstrap.com/docs/angular/changelog/


evieira357 pro commented a year ago

I just download MDB-Angular-Pro-Basic-11.0.0.zip, unzipped and run npm install, but some errors occured, see below the list, How to fix it?

PS D:\Angular\MDB-Angular-Pro-Basic> npm install npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: ng-uikit-pro-standard@11.0.0 npm ERR! Found: @angular/common@11.2.4 npm ERR! node_modules/@angular/common npm ERR! @angular/common@"~11.2.4" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer @angular/common@"^6.0.0 || ^7.0.0 || ^8.0.0" from @agm/core@1.1.0 npm ERR! node_modules/@agm/core npm ERR! @agm/core@"^1.0.0-beta.5" from the root project npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution. npm ERR! npm ERR! See C:\Users\edson\AppData\Local\npm-cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\edson\AppData\Local\npm-cache_logs\2021-03-09T11_48_20_747Z-debug.log PS D:\Angular\MDB-Angular-Pro-Basic>


Arkadiusz Idzikowski staff commented a year ago

@evieira357 please try to run the command with parameters suggested in the error message (--force or --legacy-peer-deps) or just remove agm-core package from the dependency list in package.json and remove AgmCoreModule from app.module. We will fix that in the packages.


evieira357 pro commented a year ago

hi Arkadiusz Idzikowski, i forced the installation and it is workin now, but through the process the instalation raise a bunch of warn, you can see in the image attached.enter image description here


Arkadiusz Idzikowski staff commented a year ago

@evieira357 If there are any issues with the app, please try the second solution I mentioned and remove the agm-core dependency from package.json and AgmCoreModule import from app.module. Then reinstall the dependencies with npm install.


evieira357 pro commented a year ago

Thanks for all... it`s work fine now!..

One more thing?

When will be the oficial release from Bootstrap 5 for Angular?


Arkadiusz Idzikowski staff commented a year ago

@evieira357 we do not know the exact release date of the official version yet. You can find the roadmap for MDB5 Angular here:

https://mdbootstrap.com/docs/b5/roadmap/


Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue
  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: 11.0.0
  • Device: desktop
  • Browser: chrome
  • OS: windows 10
  • Provided sample code: No
  • Provided link: No
Tags