Topic: Angular 8 - afterViewInit

Ungr pro asked 3 years ago


After updating to the last version of ng-uikit Ive got the following errors. Currently MDB for Angular 8 is unusable..

"//": "git+https://oauth2:token@git.mdbootstrap.com/mdb/angular/ng-uikit-pro-standard.git",

enter image description here


tiebird pro answered 3 years ago


I have had some similar issues. Angular compiler not being found etc...

Things I tried but failed:

  • update NPM
  • update Angular/CLI
  • remove package-lock.json
  • remote node_modules
  • install packages

Npm install WILL not install the packages!!!

My solution albeit not ideal:

  • install package per package by using:
    • npm install [name of package]
  • install dev-packages per package by using:
    • npm install --save-dev [name of package]
  • manually extract the MDB .tgz archive to the node modules

It is very time consuming but it worked for me.Still having troubles with the router but going to look into that today or tomorrow

p.s.: I am using MDB Bootstrap Angular Pro 8.0.0


Ungr pro commented 3 years ago

This was actually the only way to setup correct package of MDB. Ive done clearing npm cache, basically reiniting all I could but nothing helped.

Thank you for sharing


Damian Gemza staff answered 3 years ago


Dear @Ungr

Those problems were resolved with MDB Angular 8.

Are you sure, that you have installed the MDB Angular 8?

Please remove the package-lock.json file and remove the node_modules directory, and execute npm install command one more time.

Best Regards,

Damian


FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Closed

Specification of the issue

  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: 8.0.0
  • Device: PC
  • Browser: Chrome
  • OS: Win
  • Provided sample code: No
  • Provided link: No