Topic: Angular Bootstrap5 vs Angular Bootstrap4

marque88 priority asked 4 months ago


Hi, I'm trying to switch from MDB4 Angular to MDB5 Angular

I've notice that many components aren't available into MDB5 Angular, for example:

  • mdb-card
  • mdb-error
  • mdb-icon
  • mdb-checkbox

Will they be available in the future? Or this is a braking change beetween MDB4 Angular and MDB5 Angular


Arkadiusz Idzikowski staff answered 4 months ago


We tried to keep as many similarities as possible, but MDB5 Angular is a new library and not a continuation of MDB4 Angular, so there may be some differences.

All the components you mentioned are available in the MDB5 version. However, not all of them appear in the form of an Angular component. In some cases you just need to copy HTML code. You can find more information in our documentation:

Cards: https://mdbootstrap.com/docs/angular/components/cards/

Validation (mdb-error and mdb-success): https://mdbootstrap.com/docs/angular/forms/validation/

Icons: https://mdbootstrap.com/docs/angular/content-styles/icons/

Checkbox: https://mdbootstrap.com/docs/angular/forms/checkbox/



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • ForumUser: Priority
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB5 6.0.0
  • Device: MAC
  • Browser: Chrome
  • OS: MAC
  • Provided sample code: No
  • Provided link: No