Topic: Carousel causing page flickering

AnnaK premium asked 9 months ago


We have a problem with the carousel in that it has started to cause flickering on mobile devices' browsers. When scrolling down by keeping the finger down all the time, a page shows normal until the carousel comes into view. At that point and when scrolled passed the carousel, the page starts to flicker. It seems that the carousel is disappearing for a fraction of a second, which seems to cause the flickering.

We have Angular 12.2.8 installed And npm list ng-uikit-pro-standard shows we have ng-uikit-pro-standard@12.1.0 installed. We are using it by putting this in package.json: "git+https://oauth2:xxxxx@git.mdbootstrap.com/mdb/angular/ng-uikit-pro-standard.git"

Are these two version supposed to work together well or can an old version of the uikit cause the flickering?

Or have there been similar flickering problems with somebody else that have been resolved?

Is 12.1.0 the newest version of the Bootstrap 4-kit? Where can I see all the versions available? Cannot find them anywhere.

This problem is very evident in the IPhones but also a problem in Android.

You can see the behavior e.g. on the page https://foxdo.fi


Arkadiusz Idzikowski staff commented 9 months ago

@AnnaK You can find information about all versions and changes in our changelog: https://mdbootstrap.com/docs/angular/changelog/

With this code in package.json you always install the latest MDB version when you use npm install command. You can add #version at the end of the installation command to install a specific version, for example "git+https://oauth2:xxxxx@git.mdbootstrap.com/mdb/angular/ng-uikit-pro-standard.git#12.1.0". Could you please check if the problem occurred in older versions (for example 12.0.0)?

On which device/browser should we test that? We tried to reproduce the problem on your website but without success (android/Chrome).



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue

  • User: Premium
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB4 12.0.0
  • Device: Mobile
  • Browser: Firefox, Safari
  • OS: ios, android
  • Provided sample code: Yes
  • Provided link: Yes