Topic: Force npm install to be Angular 4 only (not ng5+)

davidasteed free asked 4 years ago


Hi, Is this the proper method to force install a version that uses no Angular components past 4.x?   i.e. I cannot use Angular 5 or later on this project. npm install angular-bootstrap-md@4.x --save (I just want to confirm that the following is valid: 1. install Angular animations 4.x: npm install @angular/animations@4.x --save + @angular/animations@4.4.6   2. Install mdbootstrap as above:λ npm install angular-bootstrap-md@4.x --save + angular-bootstrap-md@4.3.7

davidasteed free commented 4 years ago

...and install the required supporting libraries as well as indicated by the error message: λ npm install angular-bootstrap-md@4.x --save npm WARN angular-bootstrap-md@4.3.7 requires a peer of chart.js@2.5.x but none is installed. You must install peer dependencies yourself. npm WARN angular-bootstrap-md@4.3.7 requires a peer of hammerjs@2.0.x but none is installed. You must install peer dependencies yourself. npm WARN angular-bootstrap-md@4.3.7 requires a peer of font-awesome@4.7.x but none is installed. You must install peer dependencies yourself. npm WARN angular-bootstrap-md@4.3.7 requires a peer of @agm/core@~1.0.0-beta.0 but none is installed. You must install peer dependencies yourself.

davidasteed free commented 4 years ago

bump

davidasteed free answered 4 years ago


Hi Dawid, thanks for confirming!   I will close this issue. A suggestion:  At the moment, all over the 'net for different products, I find it very hard to determine what software matches what core Angular version.  It would be very very useful to have a matrix that shows exactly what MDB versions (and dependency versions) match what Angular versions.  In my case:  I am strictly limited to what Angular core version I can use for a given project.

Dawid Adach pro answered 4 years ago


Dear davidasteed, yes, as you have noticed , you can install previous verions by specifing the version after package name. The lates stable versin of MDB 4 is 4.3.7. As per dependencies - according to our installation guides you should install them manually:
npm install -–save chart.js@2.5.0 font-awesome hammerjs



FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Closed

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No
Tags