Impossible to install MDB Angular

web
mobile

Topic: Impossible to install MDB Angular

rossiello asked 3 years ago

Hijust trying to install MDB Angular via NPM, I\'m following the given instructions but i cannot installthe process stops at step 3:Step 3:  GitHub npm installnpm i angular-bootstrap-md --savewith this errors in my terminal: angular-bootstrap-md@4.3.5 requires a peer of @angular/animations@4.3.x ||^2.0.0 but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of @angular/common@4.3.x ||^2.0.0 but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of @angular/compiler@4.3.x ||^2.0.0 but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of @angular/core@4.3.x ||^2.0.0 but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of @angular/forms@4.3.x ||^2.0.0 but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of chart.js@2.5.x but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of hammerjs@2.0.x but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of font-awesome@4.7.x but none was installed. npm WARN angular-bootstrap-md@4.3.5 requires a peer of @agm/core@~1.0.0-beta.0 but none was installed. Thanks for your help Fabrizio

Dawid Adach pro answered 3 years ago

Dear Fabrizio, Please make sure that your are using Angular version > 4.0. If this is valid then you can ignore the statement. Currently, our package dependency is expecting Angular in version 4.3.x and most probably you are using version 4.4 . We will fix this in few days.
Status

Closed

Specification of the issue
  • User: Free
  • Premium support: No
  • Technology: Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No