Installed Pro version. Having some warnings as dependencies.


Topic: Installed Pro version. Having some warnings as dependencies.

Alex GuaMi pro asked 5 years ago

Unziped. then npm i after installing all this are the errors I have npm

 

WARN @ng-bootstrap/ng-bootstrap@1.0.0-beta.5 requires a peer of @angular/core@^4.0.3 but none is installed. You must install peer dependencies yourself.npm WARN @ng-bootstrap/ng-bootstrap@1.0.0-beta.5 requires a peer of @angular/common@^4.0.3 but none is installed. You must install peer dependencies yourself.npm WARN @ng-bootstrap/ng-bootstrap@1.0.0-beta.5 requires a peer of @angular/forms@^4.0.3 but none is installed. You must install peer dependencies yourself.npm WARN codelyzer@3.2.2 requires a peer of @angular/compiler@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.npm WARN codelyzer@3.2.2 requires a peer of @angular/core@^2.3.1 || >=4.0.0-beta <5.0.0 but none is installed. You must install peer dependencies yourself.npm WARN license-webpack-plugin@1.1.1 requires a peer of webpack-sources@>=1.0.0 but none is installed. You must install peer dependencies yourself.npm WARN ng-html-util@1.0.0 requires a peer of @angular/core@^4.0.3 but none is installed. You must install peer dependencies yourself.npm WARN ng-html-util@1.0.0 requires a peer of @angular/common@^4.0.3 but none is installed. You must install peer dependencies yourself.npm WARN ng-html-util@1.0.0 requires a peer of @angular/platform-browser@^4.0.3 but none is installed. You must install peer dependencies yourself.


Dawid Adach pro answered 5 years ago

Dear Alex, Angular 5 was recently released, therefore not all of the 3rd party dependencies were already updated. Warnings will disappear as soon as 3rd party libs will release their updates for Angular 5. From our side, we have tested our package against Angular 5 and we can confirm that those warnings don't affect the functionalities so you can ignore them as Angular 5 is backwards compatible with Angular 4. As a result, thus 3rd party plugins are working correctly with Angular 5, however warning that they have been fully tested with Angular 4.0.3. If you want you can use an older version of MDB Angular 4.3.7 which relays on Angular 4 , you won't face above warnings, however, this version is not fully compatible with Angular 5, therefore, we strongly encourage to use the newest version.
Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue
  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No