MDB Angular 5.0.5 after npm installation


Topic: MDB Angular 5.0.5 after npm installation

Ferdi Pekçıkmaz pro asked 5 years ago

I am getting error as shown below. What is wrong?

"ERROR in Metadata version mismatch for module C:/MyProjects/testproject/node_modules/ng-mdb-pro/node_modules/@angular/core/core.d.ts, found version 4, expected 3,
resolving symbol MDBRootModules in C:/MyProjects/testproject/node_modules/ng-mdb-pro/mdb.module.ts, resolving symbol MDBRootModules in C:/MyProjects/testproject/node_modules/ng-mdb-pro/mdb.module.ts"


jimsgroup pro commented 5 years ago

I'm getting the same problem after installing MDB pro 5.5.1

Tanya pro commented 5 years ago

Try upgrading to Angular 5. Looks like MDB 5.0.5 might not be backward compatible

Ferdi Pekçıkmaz pro commented 5 years ago

@tanya thanks your suggestion. @jimsgroup npm install -g @angular/cli@latest after that, I still got the same mistake. npm uninstall -g @angular/cli npm cache clean npm install -g @angular/cli@latest ng new myproject --style=scss I do not get an error now.

Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue
  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No