Topic: MDB Tables not working

phoenix-utbildningvxa-se priority asked 1 year ago


I want to use a datatable to present my data, and I also want to use the table editor plugin as well. However, I get a number of errors when trying to setup my table using Basic Example code from the documentation. They all relate to various unknown properties and the like, so I figured I had missed an import in my app.module file.

However, I find no module to import which seems to relate to tables in any way. The Basic Example for the Table Editor plugin contains the following line: import { MdbTableDirective } from 'mdb-angular-ui-kit/table';, but mdb-angular-ui-kit does not contain a folder "table".

When looking at the project on GitHub, I also cannot find any such folder. Is the mdb documentation faulty, or am I using the wrong version or npm package? Or is there another module I should be using?

I am using version 3.0.1 of mdb-angular-ui-kit, 5.2.3 of bootstrap, and Angular 14



The table directive and other datatable components are part of the pro version. It looks like you installed a free MDB Angular version, please follow the steps from this installation guide to resolve this problem: https://mdbootstrap.com/docs/angular/pro/installation/#section-npm

Please also take a look at this section:

https://mdbootstrap.com/docs/angular/pro/installation/#section-specific-version

You may need to specify 3.0.1 version in order to use Angular 14. Otherwise, the latest (4.0.0) will be installed and it requires Angular 15.


phoenix-utbildningvxa-se priority commented 1 year ago

Thank you for the help, that was exactly the problem. I specified to get the package from GitHub (including an access token) in package.json rather than just setting a version number, and that got me the correct version I needed.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB5 3.0.1
  • Device: Laptop
  • Browser: Chrome
  • OS: Windows 10
  • Provided sample code: Yes
  • Provided link: Yes