weas3ls priority asked 5 months ago


I'm getting the following error when attempting to run ng add mdb-angular-ui-kit

? Import all MDB modules? No
? Set up Roboto Font? Yes
? Set up Angular browser animations? Yes
? Set up Font Awesome? Yes
? Set up Charts? No
UPDATE package.json (1469 bytes)
⠇ Installing packages (npm)...npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
npm ERR! code ERESOLVE
npm ERR! ERESOLVE could not resolve
npm ERR!
npm ERR! While resolving: mdb-angular-ui-kit@2.3.0
npm ERR! Found: @angular/animations@14.0.4
npm ERR! node_modules/@angular/animations
npm ERR!   @angular/animations@"^14.0.0" from the root project
npm ERR!   peerOptional @angular/animations@"14.0.4" from @angular/platform-browser@14.0.4
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See C:\Users\weas3ls\AppData\Local\npm-cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\weas3ls\AppData\Local\npm-cache\_logs\2022-06-30T15_58_02_992Z-debug-0.log
✖ Package install failed, see above.
The Schematic workflow failed. See above.

Running Angular v14, Node v16 Auth token generated new for project


Arkadiusz Idzikowski staff answered 5 months ago


@weas3ls Versions 2.x.x supports only Angular 13, we did not release v3.x.x with support for Angular 14 yet.


branislavstp free commented 3 months ago

Hi Arkadiusz, Are there maybe estimations when will the package which can run on Angular 14 be released? Thank you.


Arkadiusz Idzikowski staff commented 3 months ago

Unfortunately, we don't have an ETA yet. I think it should be ready in the upcoming weeks but I don't want to promise anything until we know the exact (or at least estimated) date of the release.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB5 2.3.0
  • Device: Laptop
  • Browser: Chrome
  • OS: Windows 11
  • Provided sample code: Yes
  • Provided link: No