Topic: npm install angular-bootstrap-md --save

Ibrahim BOUHAJ free asked 4 years ago


Hi ,I am trying after install "npm install angular-bootstrap-md --save" , npm answered me this :  npm WARN @angular/compiler-cli@5.0.5 requires a peer of typescript@>=2.4.2 <2.5 but none is installed. You must install peer dependencies yourself. npm WARN angular-bootstrap-md@5.0.5 requires a peer of chart.js@2.5.x but none is installed. You must install peer dependencies yourself. npm WARN angular-bootstrap-md@5.0.5 requires a peer of @agm/core@~1.0.0-beta.0 but none is installed. You must install peer dependencies yourself. npm WARN tsickle@0.24.1 requires a peer of typescript@2.4.2 but none is installed. You must install peer dependencies yourself. Please , anyone help me this  ?For more information , this is it the version of : Angular CLI: 1.5.5 Node: 8.9.1 OS: darwin x64 Angular: 5.0.5 ... animations, common, compiler, compiler-cli, core, forms ... http, language-service, platform-browser ... platform-browser-dynamic, router @angular/cli: 1.5.5 @angular-devkit/build-optimizer: 0.0.34 @angular-devkit/core: 0.0.22 @angular-devkit/schematics: 0.0.38 @ngtools/json-schema: 1.1.0 @ngtools/webpack: 1.8.5 @schematics/angular: 0.1.8 typescript: 2.6.2 webpack: 3.8.1  Thank for reading my message and I hope you help , I really need it.Thank you

Dawid Adach pro answered 4 years ago


Dear Ibrahim,

You can ignore these warnings as long as you don't want to user charts nor google maps. If you however would like to use them please follow our installation guide and install missing libraries:

npm install -–save chart.js@2.5.0 font-awesome hammerjs

As far as typescript is concerned please make sure that you are using corresponding version.


Ibrahim BOUHAJ free commented 4 years ago

Thank you so much Dawid Adach !!

RobDaly free commented 1 year ago

Hi Dawid -

I seem to be having a similar issue in general, but I do want to use agm-core and it is apparently woefully behind. Any thoughts on what to do in that case where I want to use the latest MDB Pro as well as agm-core?

npm WARN @agm/core@1.1.0 requires a peer of @angular/common@^6.0.0 || ^7.0.0 || ^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN @agm/core@1.1.0 requires a peer of @angular/core@^6.0.0 || ^7.0.0 || ^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN karma-jasmine-html-reporter@1.5.4 requires a peer of jasmine-core@>=3.5 but none is installed. You must install peer dependencies yourself.


Arkadiusz Idzikowski staff commented 1 year ago

@RobDaly
Those warning should not affect how the maps work in the application. Did you encounter any problems with the map functionality?



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No
Tags