Topic: Please please please don’t use version wildcards anymore

Benny Bottema pro asked 4 years ago


Hi,

Let me start by saying that I love MDB. But:

Can you please please stop using wildcards such as ^1.2.4, where minor releases updates are allowed? You should fix the versions to a single hard version (1.2.4) or maybe allow patch updates (~1.2.4), so that whatever you publish is guaranteed to work when your users do an npm install. Removing the wildcards after downloading a zip also doesn't guarantee that I'm using the same versions as you did when releasing.

Case in point: Since I started using MDB Angular Pro, in a short while I encountered two bugs, one where the build doesn't even succeed and one bug which is invisible until you go to the right demo page. Who knows what else I'm going to find, simply because my node_modules folder contains different minor versions that yours did when you released it.

What I would love is that the zip that I download is the same as the live version of your Angular admin templates, by fixing the dependency versions.


Damian Gemza staff answered 4 years ago


Dear Benny, Today we want to update every of our zip's to contain the latest versions of our products. We have to work few hours more and our customers will get the newest zip's. Best Regards, Damian

Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: Yes
Tags