Upgrading to MDB 11.1.0


Topic: Upgrading to MDB 11.1.0

blondie63 pro premium priority asked a year ago

I've a working web app with MDB v11.0 After Angular team release v12 i'm unable to update my app to MDB v11.1.0 and Angular 11.2.14, below my package.json

ps. you have to updated list box "Specify the MDB version" 11.1.0 is missing...

Someone can help me ?

package.json of my app using MDB v11.0:

{ "name": "pic-mdb", "version": "11.0.0", "scripts": { "ng": "ng", "start": "ng serve", "build": "ng build", "test": "ng test", "lint": "ng lint", "e2e": "ng e2e", "extract-translations": "ngx-translate-extract --input ./src/app --output ./src/assets/i18n/en.json ./src/assets/i18n/it.json --sort --key-as-default-value" }, "private": true, "dependencies": { "@angular/animations": "~11.2.11", "@angular/cdk": "^11.2.10", "@angular/common": "~11.2.11", "@angular/compiler": "~11.2.11", "@angular/core": "~11.2.11", "@angular/forms": "~11.2.11", "@angular/google-maps": "^11.2.10", "@angular/localize": "^11.2.11", "@angular/platform-browser": "~11.2.11", "@angular/platform-browser-dynamic": "~11.2.11", "@angular/router": "~11.2.11", "@fortawesome/fontawesome-free": "^5.15.3", "@ngrx/data": "^11.1.1", "@ngrx/effects": "^11.1.1", "@ngrx/entity": "^11.1.1", "@ngrx/router-store": "^11.1.1", "@ngrx/store": "^11.1.1", "@ngrx/store-devtools": "^11.1.1", "@ngx-translate/core": "^13.0.0", "@ngx-translate/http-loader": "^6.0.0", "chart.js": "^2.9.4", "easy-pie-chart": "2.1.x", "hammerjs": "^2.0.8", "lodash": "^4.17.21", "messageformat": "^2.3.0", "moment": "^2.29.1", "ng-uikit-pro-standard": "file:ng-uikit-pro-standard-11.0.0.tgz", "ngx-translate-messageformat-compiler": "^4.9.0", "rxjs": "~6.6.7", "screenfull": "^5.1.0", "tslib": "^2.2.0", "zone.js": "~0.11.4" }, "devDependencies": { "@angular-devkit/build-angular": "^0.1102.9", "@angular/cli": "^11.2.10", "@angular/compiler-cli": "~11.2.11", "@angular/language-service": "~11.2.11", "@biesbjerg/ngx-translate-extract": "^7.0.4", "@biesbjerg/ngx-translate-extract-marker": "^1.0.0", "@ngrx/schematics": "^11.1.1", "@types/googlemaps": "^3.43.3", "@types/jasmine": "^3.6.9", "@types/jasminewd2": "^2.0.8", "@types/lodash": "^4.14.168", "@types/node": "^14.14.41", "eslint": "^7.25.0", "jasmine-core": "~3.7.1", "jasmine-spec-reporter": "~6.0.0", "karma": "~6.3.2", "karma-chrome-launcher": "~3.1.0", "karma-coverage-istanbul-reporter": "~3.0.3", "karma-jasmine": "~4.0.1", "karma-jasmine-html-reporter": "^1.5.4", "ngrx-store-freeze": "^0.2.4", "protractor": "~7.0.0", "ts-node": "~9.1.1", "typescript": "~4.1.5", "xlsx": "^0.16.9" }, "license": "Custom license" }


Grzegorz Bujański staff commented a year ago

Unfortunately there may be problems at the moment because we haven't updated our package to the latest version of angular yet. We will do it as soon as possible.


blondie63 pro premium priority commented a year ago

Do you mean Angular 12.x ? Because this i know, but i'm talking about 11.x


Arkadiusz Idzikowski staff commented a year ago

@blondie63 Can you provide more information about the problems with installation?


blondie63 pro premium priority commented a year ago

You can download my logs here: https://drive.google.com/file/d/1PH8MagZ8jb0261o7w3nN4b-3h9NDb7Jf/view?usp=sharing

You can see that there are many problems with PostCss


Arkadiusz Idzikowski staff commented a year ago

@blondie63 Which version of node/npm do you use? Please try to use node LTS version with npm 6 or run the command suggested by npm: npm install --force.


blondie63 pro premium priority commented a year ago

For my Master branch (MDB 11.0.0) i'm using this: node v16.1.0 (npm v7.11.2) and app start without problems but i cannot upgrade it to MDB 11.1.0 and Angular 11.2.14 (last 11.x) What can i do ?

Thanks for help


Arkadiusz Idzikowski staff commented a year ago

@blondie63 Did you try the solutions I mentioned in my previous comment?

Please try to use the latest stable version of node (14.17.0) with npm 6 or try to use installation commands suggested by the npm in the error message: npm install --force or npm install --legacy-peer-deps.


blondie63 pro premium priority answered a year ago

Eventually I was able to update the application with node v16.2.0 (npm v7.15.0) using --force! But I hope that you will soon release the MDB version for Angular 12 which solves several problems of old dependencies

Best regards

Mauro


Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue
  • User: Pro
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB4 11.0.0
  • Device: web
  • Browser: chrome
  • OS: macos
  • Provided sample code: No
  • Provided link: No