Topic: vanilla download MDB-Angular-Small-Bundle-12.0.0 and npm install under MDB-Angular-Admin-Pro fails

itpartner pro asked 1 year ago


Expected behavior npm install successful

Actual behavior successful run of npm install was expected. I am just trying the vanilla download from my account's download and unzipped and trying to run this. I have node latest, angular latest installed.

Please help

Resources (screenshots, code snippets etc.) While resolving: ng-admin-pro@12.0.0 Found: @angular/common@12.2.13 node_modules/@angular/common @angular/common@"~12.2.2" from the root project

Could not resolve dependency: peer @angular/common@"^9.1.0 || ^10.0.0" from @agm/core@3.0.0-beta.0 node_modules/@agm/core @agm/core@"^3.0.0-beta.0" from the root project

Fix the upstream dependency conflict, or retry this command with --force, or --legacy-peer-deps to accept an incorrect (and potentially broken) dependency resolution.


Grzegorz Bujański staff answered 1 year ago


I downloaded the zip package and checked what was going on. Unfortunately, I am unable to reproduce this issue. Everything was installed correctly.

Please try again, maybe it was a temporary problem with npm servers. If the error show again, writes exactly what commands you use before the error occurs, what specific node version you are using (16.13.0 LTS or 17.1.0 current). And add a screenshot of the console with errors



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: MDB5 1.3.0
  • Device: surface
  • Browser: n/a
  • OS: windows 10 64bit
  • Provided sample code: No
  • Provided link: No