Warnings on dependencies


Topic: Warnings on dependencies

Simone Miorelli free asked 4 years ago

Hello,I'm having some troubles installing the Angular version of MDB. The problem is that when I run the command
npm i angular-bootstrap-md --saveI get the following warnings
npm WARN angular-bootstrap-md@5.1.2 requires a peer of @angular/animations@5.0.0 - 5.1.2 but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of @angular/common@5.0.0 - 5.1.2 but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of @angular/compiler@5.0.0 - 5.1.2 but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of @angular/core@5.0.0 - 5.1.2 but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of @angular/forms@5.0.0 - 5.1.2 but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of chart.js@2.5.x but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of hammerjs@2.0.x but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of font-awesome@4.7.x but none is installed. You must install peer dependencies yourself.npm WARN angular-bootstrap-md@5.1.2 requires a peer of @agm/core@~1.0.0-beta.2 but none is installed. You must install peer dependencies yourself.npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
These are the settings I'm using:
OS: Ubuntu 16.04.2 LTSAngular CLI: 1.5.0Angular: 5.0.0-rc.0Node: 9.2.1
What could be the problem?Thank you in advance, RegardsS

Vitor Pavanelli free commented 4 years ago

Hi Simone, This is issue it not related to MDBoostrap, but more one the Angular APIs version you are using. When I create my Angular project, it installed Angular 5.0.0 version and since MDBoostrap is using 5.0.0, it doesn't give me the warning. If you want to see the warnings gone, you will need to set your Angular project to have Angular 5.0.0 version instead of 5.1.x. Thank you, Vitor P.S: I'm just a user and not related to MDBoostrap team.

Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue
  • User: Free
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: Yes
  • Provided link: No
Tags