Form Label Does not go up on label click


Topic: Form Label Does not go up on label click

AdamEsterle asked 3 years ago

http://pasteboard.co/8fMbMK4nC.png If you click the label directly (put cursor on letter and click), the label does not pop up for you to enter text You have to click right between the label and the bottom border of the input field. I think you should be able to click that label to set focus on the form and then the label will be triggered and pop up

Michal Szymanski staff answered 3 years ago

Paste your code here and write me please which browser do you use.

AdamEsterle answered 3 years ago

LATEST CHROME <div class="form-group"> <div class="md-form"> <input class="form-control" name="name" type="text"> <label for="name">Name</label> </div> </div> Clicking the "Name" label does not put focus in the input box nor trigger the label to pop up You have to click PRECISELY between the "Name" label and the bottom border of the input box

sirdante pro answered 3 years ago

try this <div class=”form-group”> <div class=”md-form”> <input class=”form-control” name=”name” id="name" type=”text”> <label for=”name”>Name</label> </div> </div> in input id="x" and in label for="x".

gmuckelvene pro answered 3 years ago

I'm having the same issue. I'm also using the latest version of Google Chrome. The text area just allows me to type right over the label without the animation firing. Any help would be appreciated.

Michal Szymanski staff answered 3 years ago

What about this code?
<div class="md-form">
    <input type="text" id="form1" class="form-control">
    <label for="form1" class="">Example label</label>
</div>

AdamEsterle answered 3 years ago

Thank you! It works fine! I did forget the id = name (which corresponds to the label's for) I only had the name attribute set, I will make the change!

gmuckelvene pro answered 3 years ago

I wasn't as lucky. I'm using Visual Studio 2013 and I am putting the code into my .aspx page. I'm having all kinds of issues with small things. Like the waves-effect doesn't work on anything. Cant get a dropdown to open in my navbar. With this many issues i'm sure its something on my end i'm not doing correctly. I'm pasting the examples in but it doesn't seem to be working correctly.

gmuckelvene pro answered 3 years ago

fixed it! Was getting a conflicting CSS on my masterpage.

Ybara answered 2 months ago

I had the same problem, I found the solution, I put the latest version of scripts and it worked. I use the contact form v2. I hope it will help :)


Please insert min. 20 characters.
Status

Answered

Specification of the issue
  • User: Free
  • Premium support: No
  • Technology: General Bootstrap questions
  • MDB Version: -
  • Device: -
  • Browser: -
  • OS: -
  • Provided sample code: No
  • Provided link: No