Topic: Adding vue mdb to an existing project/folder is throwing errors

harshmairh free asked 7 months ago


Expected behavior

I am trying to install mdb-vue to an existing project. I installed mdb-cli first, login using the "mdb login" command, and then to add it to my existing project I am running this command "vue add mdb' but I get an error when I run this command. The error message is as follows:

npm ERR! code ETARGET npm ERR! notarget No matching version found for mdbvue@1.12.0. npm ERR! notarget In most cases you or one of your dependencies are requesting npm ERR! notarget a package version that doesn't exist. npm ERR! A complete log of this run can be found in:

Resources (screenshots, code snippets etc.)enter image description here


Mikołaj Smoleński staff commented 7 months ago

Most probably you want to install the latest MDB5 Vue UI KIT, but use cli plugin for v4. Please try typing vue add mdb5 instead of vue add mdb.

Keep coding, Mikołaj from MDB


harshmairh free commented 7 months ago

That worked, thank you!!



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Vue
  • MDB Version: MDB5 1.12.0
  • Device: Laptop
  • Browser: Chrome
  • OS: Windows 10
  • Provided sample code: No
  • Provided link: No