Can not build my project after update of dependencies with n

web
mobile

Topic: Can not build my project after update of dependencies with npm. (MDB Vue Update v.5.0.0)

Ingvaldsen pro premium asked 9 months ago

[INFO] ERROR in ./node_modules/mdbvue/src/components/pro/Parallax.vue [INFO] Module not found: Error: Can't resolve 'sass-loader' in 'C:\Privat\gambling\frontend\node_modules\mdbvue\src\components\pro' [ERROR] npm ERR! code ELIFECYCLE [ERROR] npm ERR! errno 1 [INFO] @ ./node_modules/mdbvue/src/components/pro/Parallax.vue 2:2-383 [ERROR] npm ERR! frontend@1.0.0 build: node build/build.js [ERROR] npm ERR! Exit status 1 [INFO] @ ./node_modules/mdbvue/src/index.js [ERROR] npm ERR! [ERROR] npm ERR! Failed at the frontend@1.0.0 build script. [INFO] @ ./src/main.js [ERROR] npm ERR! This is probably not a problem with npm. There is likely additional logging output above. [INFO] [INFO] Build failed with errors.


Ingvaldsen pro premium commented 9 months ago

I figured it out. I had to install this: npm install --save-dev node-sass sass-loader


Bartłomiej Malanowski staff pro premium commented 9 months ago

I'm glad you found a solution to your issue. Also, thank you for sharing it with us!


Please insert min. 20 characters.
Status

Resolved

Specification of the issue
  • User: Pro
  • Premium support: Yes
  • Technology: Vue
  • MDB Version: 4.8.2
  • Device: Laptop
  • Browser: Chrome
  • OS: Windows 10
  • Provided sample code: No
  • Provided link: No
Tags