Topic: remote: The project you were looking for could not be found.

mikkelduif free asked 2 years ago


Expected behavior Installing MDB Pro version. I have already installed MDB Free version into my project, and need to replace with pro version.

I follow the steps as stated in the guide.

Actual behavior error Command failed. Exit code: 128 Command: git Arguments: ls-remote --tags --heads https://oauth2:@git.mdbootstrap.com/mdb/vue/mdb-vue-dev.git Directory: /Users/... Output: remote: The project you were looking for could not be found. fatal: repository 'https://oauth2:@git.mdbootstrap.com/mdb/vue/mdb-vue-dev.git/' not found

Resources (screenshots, code snippets etc.)


Magdalena Dembna staff commented 2 years ago

Can you add a snippet from your package.json file? You shouldn't install dependencies from our dev repo (as an error suggests), but vu-pro instead:

https://mdbootstrap.com/docs/vue/getting-started/quick-start/#existing-project


mikkelduif free commented 2 years ago

these are my dependencies (Token removed):

"dependencies": { "@nuxtjs/axios": "^5.12.0", "mdbvue": "git+https://oauth2:@git.mdbootstrap.com/mdb/vue/vu-pro.git", "nuxt": "^2.14.0" },


Magdalena Dembna staff answered 2 years ago


@mikkelduif I will write an instruction once again, hopefully, more clearly:

  1. Open your MDB Package from ZIP (MDB-Vue-Pro-Basic-6.7.1);
  2. Copy mdb folder to your Nuxt project (you'll find a tgz file inside)
  3. In your package.json add the following dependency: "mdbvue": "./mdb/mdbvue/mdbvue-6.7.1.tgz"
  4. Make sure that any reference to the mdbvue nuxt module is removed from nuxt.config.js (it shouldn't be listed as a module or has its own key mdbvue)
  5. This step depends on Nuxt version - you can either open App.js file and add the following imports or create a plugin (for example plugins/style.js) and place them there:

    import 'bootstrap-css-only/css/bootstrap.min.css'

    import 'mdbvue/lib/css/mdb.min.css'

    import '@fortawesome/fontawesome-free/css/all.min.css'

    6 This step applies only if you've created a plugin - go the nuxt.config.js and add you plugin: plugins: [ { src: '~/plugins/style.js'} ]

    7 Install your dependencies with npm i and run your app.

If you're still getting errors, please provide a screenshot - but if you will follow those instructions correctly, you certainly won't get a warning about using file directly - I've written three times already about copying .tgz file and installing dependency from it.

Using Nuxt module makes things easier but it's possible to use libraries without it. Best regards, Magdalena


Magdalena Dembna staff answered 2 years ago


I've checked and your licence (1 project) doesn't grant access to our GitLab - which is the source of the following error. To install a pro version in your existing project follow those steps:

  1. Copy .tgz file from a ZIP package to your project's directory
  2. In package.json link mdbvue dependency to this .tgz file
  3. run npm i

Best regards, Magdalena


mikkelduif free commented 2 years ago

Hi Magdalena,

This does still not work. I now get the following error:

✖ Nuxt Fatal Error │ │ │ │ Error: Cannot find module 'mdbvue/nuxt' │ │ Require stack: │ │ - /Users/.../Documents/GitHub/.../node_modules/@nuxt/core/dist/core.js │ │ - /Users/.../Documents/GitHub/.../node_modules/@nuxt/cli/dist/cli-index.js │ │ - /Users/.../Documents/GitHub/.../node_modules/@nuxt/cli/dist/cli.js │ │ - /Users/.../Documents/GitHub/.../node_modules/nuxt/bin/nuxt.js


mikkelduif free commented 2 years ago

I have also tried with the Vue Boilerplate, which does also not work. It gives the same error. Please solve this issue as soon as possible.


Magdalena Dembna staff commented 2 years ago

Your licence doesn't contain our PRO nuxt module - you need to remove reference to it from nuxt.config.js and manually import CSS styles in you App.js file:

import 'bootstrap-css-only/css/bootstrap.min.css' import 'mdbvue/lib/css/mdb.min.css' import '@fortawesome/fontawesome-free/css/all.min.css'


mikkelduif free commented 2 years ago

Hi Magdalena, I don't understand this as I have bougth the Pro package which says it contains all pro features + vue version. This is a Nuxt project I am developing, so I really need this to work with Nuxt. Please resolve this ASAP as I am already delayed by MBD integration into the project is not working. Thanks


Magdalena Dembna staff commented 2 years ago

https://mdbootstrap.com/docs/vue/getting-started/quick-start/#nuxt There is a note which informs that mdbvue nuxt module is available for users with GitLab access. As I wrote in my previous comment: add the .tgz dependency in your package.json file and those three imports in App.js instead of trying to use mdbvue nuxt module in nuxt.config.js (remove mdbvue from this file) - everything should work. Best regards, Magdalena


mikkelduif free commented 2 years ago

Hi Magdalena, this does not work. Please fix this issue. It says that I can use with the file directly. It says GitLab OR .tgz file.

I have bougth the Pro license as specified.

If you cannot solve this issue immediately, please provide me that GitLab access. I can simply not afford to waste more time on this. Your slow responses and support has already cost me more than the benefit of your product. This is not okay. I expect you to resolve this NOW.

/ Mikkel



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Vue
  • MDB Version: 6.7.1
  • Device: MacBook Pro
  • Browser: None
  • OS: Mac OS
  • Provided sample code: No
  • Provided link: Yes