TreeView not working: Can't resolve 'vue' in


Topic: TreeView not working: Can't resolve 'vue' in ...node_modules/mdb-vue-tree-view/js

Bruckner pro premium priority asked 3 months ago

I wanted to use the TreeView-Plugin.

But i'am getting the error "Can't resolve 'vue' in ...node_modules/mdb-vue-tree-view/js"

  1. Installation via yarn worked: (yarn add git+https://oauth2:mytoken@git.mdbootstrap.com/mdb/vue/mdb5/plugins/prd/treeview)

  2. IDE (PHPStorm) does not show any error on the import-line: import { MDBTreeview } from "mdb-vue-tree-view"; dependency is found (can click on it ;-))

  3. Other Components like MDBAutocomplete are woking too.


Bruckner pro premium priority answered 3 months ago

Issue has been fixed

I don't know why, but after running "yarn add .../treeview" vue has been removed from node_modules.

just a yarn install did the trick ;-).


FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Closed

Specification of the issue
  • User: Pro
  • Premium support: Yes
  • Technology: MDB Vue
  • MDB Version: MDB5 1.11.0
  • Device: Mac
  • Browser: Chrome
  • OS: OS X
  • Provided sample code: No
  • Provided link: Yes
Tags