Topic: Vue Admin Template Dropdown "The .native modifier for v-on is only valid on components but it was used on <li>"

MartinAmsinck free asked 3 years ago


Expected behavior**no errors in console **Actual behavior

vue.esm.js?efeb:628 [Vue warn]: The .native modifier for v-on is only valid on components but it was used on


Magdalena Dembna staff answered 3 years ago


Vue has released its newest version few days ago, and those warnings appeared - we are working on updating those components - although our next release will not take place until 20.01. Right now MDB Vue is compatible with 2.6.10. Kind regards, Magdalena


Tenarius free answered 3 years ago


I have the same issue. When using the mdb-dropdown element, the following errors are displayed:

[Vue warn]: The .native modifier for v-on is only valid on components but it was used on <li>.
[Vue warn]: The .native modifier for v-on is only valid on components but it was used on <a>.
[Vue warn]: The .native modifier for v-on is only valid on components but it was used on <li>.

Im using Laravel 6.x.

Edit: Its the same when i clicking on the mdb-navbar.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Vue
  • MDB Version: 6.2.0
  • Device: Dell xps 15
  • Browser: Chrome
  • OS: Win 10
  • Provided sample code: No
  • Provided link: Yes