Topic: Vue perfect scrollbar dependency not found

Tomas HD free asked 3 years ago


Expected behavior Compile without errors

Actual behavior Compilation fails

Resources (screenshots, code snippets etc.) When running vue serve command, the project tries to be built and compiled but the following error appears:

This dependency was not found:

  • vue-perfect-scrollbar in ./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./node_modules/mdbvue/src/components/Scrollbar.vue?vue&type=script&lang=js&

To install it, you can run: npm install --save vue-perfect-scrollbar


Magdalena Dembna staff answered 3 years ago


Hi, Have you install all dependencies from package.json in our package? Can you walk me through your installation process? I encourage you to checkout our tutorial on getting started: https://mdbootstrap.com/docs/vue/getting-started/download/ Kind regards, Magdalena



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Vue
  • MDB Version: 5.2.0
  • Device: PC
  • Browser: Chrome
  • OS: Windows
  • Provided sample code: No
  • Provided link: No