Topic: Wrong version of eslint is being installed with MDB package - info for users and MDB developers

xdon82 free asked 3 years ago


This is just well known issue and info for MDB developers at least it's an issue for MDBVue

npm ERR! peer dep missing: eslint@^5.0.0, required by eslint-plugin-vue@5.2.3

You force to install Eslint v6 which is not compatible with other eslint plugins versions you put in dependencies in mdbvue. As far only Eslint v5 is compatible

As I said I already know the solution Have a good day :)


Mikołaj Smoleński staff answered 3 years ago


Could you please provide your solution for that issue? It might be helpful for us and other MDB users.

Best regards


xdon82 free commented 3 years ago

just install eslint v5 ...

if actual installed is v6 then

npm uninstall eslint

I installed latest ver of eslint v5

npm install --save-dev eslint@5.16.0


Mikołaj Smoleński staff commented 3 years ago

Thanks for sharing your solution.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB Vue
  • MDB Version: 5.8.2
  • Device: pc
  • Browser: Edge Chromium
  • OS: win10
  • Provided sample code: No
  • Provided link: No