lGabranth priority asked 5 months ago


Expected behavior

Using yarn 4 I would expect to be able to add MDB packages to my application in order to use it

Actual behavior

Currently it is impossible to install any MDBVue packages using yarn 4.

yarn add 'mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-pro-essential'➤ YN0000: · Yarn 4.1.0➤ YN0000: ┌ Resolution step➤ YN0000: ⠙ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠹ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠸ mdb-vue-ui-kit@git+https://oauth2:7ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠼ mdb-vue-ui-kit@git+https://oauth2ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠴ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠦ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠧ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠇ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠏ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠋ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠙ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠹ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠸ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0000: ⠼ mdb-vue-ui-kit@git+https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-➤ YN0001: │ Error: mdb-vue-ui-kit@https://oauth2:ACCESS_TOKEN@git.mdbootstrap.com/mdb/vue/mdb5/prd/mdb5-vue-ui-kit-pro-essential#commit=061a400dece3d6b537b89f034d266e93ae3ccf1d: Manifest not found at AE.find (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:140:120021) at async C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:559:12938 at async Object.bZe (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:140:53847) at async G2.resolve (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:559:12899) at async Dd.resolve (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:141:1451) at async Dd.resolve (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:141:1451) at async C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:210:7249 at async Ky (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:140:53910) at async ne (C:\Users\Charles\AppData\Local\node\corepack\yarn\4.1.0\yarn.js:210:7231) at async Promise.allSettled (index 0)➤ YN0000: └ Completed in 1s 355ms➤ YN0000: · Failed with errors in 1s 372ms

Resources (screenshots, code snippets etc.)


Bartosz Cylwik staff answered 5 months ago


Hi! Unfortunately it seems like you have to install the package via npm as there is some issue with installing mdb vue ui kit via yarn 4. We will try to find out why the issue with yarn 4 is happening.

Best Regards!

btw, I've editted your post to hide the access token



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • ForumUser: Priority
  • Premium support: Yes
  • Technology: MDB Vue
  • MDB Version: MDB5 4.1.1
  • Device: PC
  • Browser: N/A
  • OS: Windows 11
  • Provided sample code: No
  • Provided link: Yes