Topic: Is there an upgrade guide available?

EdenredUSFleet priority asked 2 months ago


I'm going through the process of updating an application that uses MDB from ng12 to ng17. Here's a snippet of the package.json:

"mdb-angular-ui-kit": "file:mdb-angular-ui-kit-1.1.0.tgz", "mdb-calendar": "file:mdb-calendar-12.0.0.tgz", "mdb-color-picker": "file:mdb-color-picker-12.0.0.tgz", "mdb-draggable": "file:mdb-draggable-12.0.0.tgz", "mdb-file-upload": "file:mdb-file-upload-12.0.0.tgz", "mdb-filter": "file:mdb-filter-12.0.0.tgz", "mdb-sortable": "file:mdb-sortable-12.0.0.tgz", "mdb-table-editor": "file:mdb-table-editor-12.0.0.tgz", "mdb-wysiwyg": "file:mdb-wysiwyg-12.0.0.tgz", "ng-uikit-pro-standard": "file:ng-uikit-pro-standard-12.0.0.tgz"

Because 1.1.0 doesn't support the latest Angular, I need to upgrade MDB to 6.0.0 and v15 for those individual modules. Here's my new package.json:

"mdb-angular-ui-kit": "file:mdb-angular-ui-kit-6.0.0.tgz", "mdb-calendar": "file:mdb-calendar-15.0.0.tgz", "mdb-color-picker": "file:mdb-color-picker-15.0.0.tgz", "mdb-draggable": "file:mdb-draggable-15.0.0.tgz", "mdb-file-upload": "file:mdb-file-upload-15.0.0.tgz", "mdb-filter": "file:mdb-filter-15.0.0.tgz", "mdb-sortable": "file:mdb-sortable-15.0.0.tgz", "mdb-table-editor": "file:mdb-table-editor-15.0.0.tgz", "mdb-wysiwyg": "file:mdb-wysiwyg-15.0.0.tgz", "ng-uikit-pro-standard": "file:ng-uikit-pro-standard-15.0.0.tgz"

I noticed that the select component is no longer in the mdb-angular-ui-kit module, but there is one in ng-uikit-pro-standard, so that changed my imports from import { MdbSelectModule } from 'mdb-angular-ui-kit/select'; to import { MdbSelectModule } from 'ng-uikit-pro-standard';

Unfortunately, that's causing errors in some of the attributes of the mdb-select and mdb-option elements. I've seen people asking questions about mdb-select-2 and seen examples here with it and mdb-select-option, but I haven't seen any official examples or even an explanation of what mdb-select-2 is compared to mdb-select and when/if I might want to use it. Can you point me to some documentation about that?


Rafał Seifert staff commented 2 months ago

Please have a look at the current select documentation: https://mdbootstrap.com/docs/angular/forms/select mdb-select-2 is component from MDB4 package. In MDB5 you import Select like so: import { MdbSelectModule } from 'mdb-angular-ui-kit/select';

In the docs you can also find examples how to use this component.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue

  • ForumUser: Priority
  • Premium support: Yes
  • Technology: MDB Angular
  • MDB Version: MDB5 6.0.0
  • Device: PC
  • Browser: Chrome
  • OS: Mac
  • Provided sample code: No
  • Provided link: No