MDBootstrap Pro + Plugins: compatibility with Angular 9?

web
mobile

Topic: MDBootstrap Pro + Plugins: compatibility with Angular 9?

Giovanni De Stefano pro asked 2 weeks ago

Hello,

When both MDBootstrap Pro and Plugins will be compatible with Angular 9?

In the meantime can I already start with a fresh project with Angular 9, MDB Pro 8.9.0 and Plugins 8.8.2?

Thank you, Giovanni


tommykjensen pro commented 2 weeks ago

I have upgraded one of my small projects to angular 9 and have so far seen no issues with the components I use.


Giovanni De Stefano pro commented 2 weeks ago

Thank you, I will give it a shot. In the meantime I hope someone from MDB will also comment on this 😁


Konrad Stępień staff commented 2 weeks ago

It is scheduled for approximately a month.

Until now, it happened that several people updated their projects to angular 9 and did not encounter errors, but there were also several threads that there were problems.


Giovanni De Stefano pro commented 2 weeks ago

Thank you Konrad, in fact in my case I have multi-select that goes crazy when I select or deselect all as a bunch of events are thrown (number of options + 1 to be more precise) and and the model becomes inconsistent. I am now trying to figure our how to really rebuild the interface with all versions as it was before (strangely enough just checking out the latest working version is not sufficient....).


Konrad Stępień staff commented 2 weeks ago

The best way is waiting for release v.9.0.0.

So far, we do not support this version and it is hard for us to help in cases when someone uses MDB package with angular 9


Please insert min. 20 characters.
Status

Open

Specification of the issue
  • User: Pro
  • Premium support: No
  • Technology: Angular
  • MDB Version: 8.9.0
  • Device: All
  • Browser: All
  • OS: All
  • Provided sample code: No
  • Provided link: No
Tags