Topic: bootstrap-material-design build fails when building latest 4.x version

Mantas Mantas free asked 2 years ago


Expected behavior

npm install . should complete without errors

Actual behavior npm install .

[.. skipped ..]

bootstrap-material-design@4.1.2 build:js E:\prj\github\bootstrap-material-design rollup js/index.js --output.file=dist/js/bootstrap-material-design.js -m --config=rollup.config.js

js/index.js → dist/js/bootstrap-material-design.js... (!) Error when using sourcemap for reporting an error: Can't resolve original location of error. js\baseInput.js: (1:9) [!] Error: 'createForOfIteratorHelperLoose' is not exported by rollupPluginBabelHelpers.js, imported by js\baseInput.js https://rollupjs.org/guide/en/#error-name-is-not-exported-by-module js\baseInput.js (1:9) 1: import Base from "./base"; ^ 2: import Util from "./util"; Error: 'createForOfIteratorHelperLoose' is not exported by rollupPluginBabelHelpers.js, imported by js\baseInput.js at error (E:\prj\github\bootstrap-material-design\node_modules\rollup\dist\shared\node-entry.js:5400:30)

Resources (screenshots, code snippets etc.) Take the latest 4.x version from github. Build on Windows.


Marcin Luczak staff answered 2 years ago


Hello,

It seems that you've downloaded a repository that is not maintained/supported. Please download the Material Design for Bootstrap from the link below instead: https://github.com/mdbootstrap/material-design-for-bootstrap

Regards, Marcin



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: General Bootstrap questions
  • MDB Version: -
  • Device: PC
  • Browser: node.js
  • OS: windows
  • Provided sample code: No
  • Provided link: Yes