Cannot install the Pro version of MDB React


Topic: Cannot install the Pro version of MDB React

mattagape pro asked 4 years ago

I'm actually using 4.8.1 (React) I am unable to use MDB React Pro in my app using npm i or Gitlab.  When I download 'MDB-REACT-PRO-NPM_4.8.1.ZIP' and then attempt to do npm i , I do not get a node_modules folder. When I download 'MDB-REACT-PRO_4.8.1.ZIP', I am able to get the node_modules folder, but when I do npm start, I get this error: "An unexpected error occurred: "spawn E2BIG" . I have also attempted to use the Gitlab Repository.  I was able to paste my ssh-rsa... value into Gitlab.  But, when I attempted to do git clone https://github.com/mdbootstrap/react-bootstrap-with-material-design . , I get this error: fatal: destination path '.' already exists and is not an empty directory. I have attempted to run my React app using Pro version Components, but I get undefined for those components, thus I do not have access to them. If you could provide any help for me in getting the PRO version installed, I would greatly appreciate it.  Thank you. Gitlab username:   @mattagape

Bartłomiej Malanowski staff pro premium commented 4 years ago

Could you please provide me your GitLab username?

mattagape pro answered 4 years ago

I got an error when I tried to "ADD COMMENT" above. Gitlab username:   @mattagape email: mattagape@me.com
Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue
  • User: Pro
  • Premium support: No
  • Technology: MDB React
  • MDB Version: 4.7.1
  • Device: Macbook Pro
  • Browser: Chrome
  • OS: OSX High Sierra
  • Provided sample code: No
  • Provided link: No