Topic: Error: Node Sass version 6.0.0 is incompatible with ^4.0.0.

Kaherdino priority asked 1 year ago


Expected behavior Change .css to .scss to be able to easily add and custom variable. I've followed this tuto : https://mdbootstrap.com/docs/react/getting-started/installation/#sass

Actual behavior When I try npm start, I've got this error in terminal and browser : "Error: Node Sass version 6.0.0 is incompatible with ^4.0.0."

I'm using node v16.2.0

Then I try to install an older version of node-sass (npm install node-sass@4.14.1) and the I've got this error :

Error: resolve-url-loader: CSS error source-map information is not available at url() declaration (found orphan CR, try removeCR option)


Krzysztof Wilk staff commented 1 year ago

Hi!

Could you precise which package do you use? In the specification of this issue I see MDB5 1.0.0-beta5, but you provided a link to the React MDB4 documentation. Could you also try installing node-sass with version 4.0.0 or lower?

Keep coding!



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB React
  • MDB Version: MDB5 1.0.0-beta5
  • Device: PC
  • Browser: Chrome
  • OS: Windows
  • Provided sample code: No
  • Provided link: Yes