Topic: React Carousel throw warning in console

FairfaaxSt. free asked 2 years ago


Hi everyone! I'm a newbiee in Reactjs, I install via npm the mdb dependency and I use the carousel component into my app. It works perfectly but throw me a warning with this message: "1.chunk.js:49454 Warning: Legacy context API has been detected within a strict-mode tree.

The old API will be supported in all 16.x releases, but applications using it should migrate to the new version.

Please update the following components: r"

I don't know if the new version is from Pro plan or is for free too.

Ps: Sorry for my english, if you don't understand me please tell me and I'll try to write the question different


Piotr Glejzer staff commented 2 years ago

It's just a warning. We will fix this warning in the future. It does mean that in React 17 it will not work but React still use 16 version, so don't worry.


FairfaaxSt. free commented 2 years ago

Thank you so much for the reply Piotr! I won't worry so :)



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB React
  • MDB Version: 4.27.0
  • Device: laptop
  • Browser: chrome
  • OS: macOs
  • Provided sample code: No
  • Provided link: No