Topic: How to work with Ruby on Rails 7 and MDB5

waynehiner priority asked 1 year ago


Expected behavior Interface with Ruby on Rails 7 with Bootstrap installed "the Rails way" using ImportMaps for JS and compiling SCSS with the Rails Asset Pipeline.

Actual behavior MDB5 expects to use the bundled version of Bootstrap (5.0.0.2 Beta) and I am using Bootstrap 5.2.3 in my RoR project. There is also a JQuery call in the MDB5 JS and I am using Alpine JS which has some issues when running with JQuery.

Resources (screenshots, code snippets etc.) I don't have any resources to add as this is a general setup question. I'm looking for some insight into the best way to integrate MDB5 with Rails 7 if others have successfully done so.


Kamila Pieńkowska staff answered 1 year ago


JQuery is not included in the MDB5 package by default. We only include an option to use it if clients want to.

We plan to launch a tutorial for using MDB5 with Rails with our next release.


recunet priority commented 11 months ago

I have the same problem, please we need this tutorial



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue

  • ForumUser: Priority
  • Premium support: Yes
  • Technology: MDB Standard
  • MDB Version: MDB5 6.1.0
  • Device: MacBook Air and Mini
  • Browser: All
  • OS: MacOS X Monterey
  • Provided sample code: No
  • Provided link: No