Topic: MDB Standard Plugins : Rebuild all.min.js

welprog free asked 3 years ago


Hello,

Is it possible to have some information about how plugins and all.min.js are built ?

I had to customize "table editor" and "file upload" to handle some specific issues i encountered.

In production, I would like to only link a custom all.min.js instead of all my customized plugins one by one.

Correct me if I'm wrong, but I can't find any build files on the gitlab. I started creating my own "minify/rollup" task to build the plugins but cannot generate anything as complex and functional as the originals.

Regards.

PS: I'm actually using MDB5 3.6.0 but this version is not listed


mdoma free answered 2 years ago


I submitted the npm run startMDBa and got the following error

/.../mdb/node_modules/copy-webpack-plugin/node_modules/schema-utils/dist/validate.js:105 throw new _ValidationError.default(errors, schema, configuration); ^

ValidationError: Invalid options object. Copy Plugin has been initialized using an options object that does not match the API schema. - options[0] misses the property 'patterns'. Should be: [non-empty string | object { from, to?, context?, globOptions?, filter?, transformAll?, toType?, force?, priority?, info?, transform?, transformPath?, noErrorOnMissing? }, ...] (should not have fewer than 1 item) - options[1] misses the property 'patterns'. Should be: [non-empty string | object { from, to?, context?, globOptions?, filter?, transformAll?, toType?, force?, priority?, info?, transform?, transformPath?, noErrorOnMissing? }, ...] (should not have fewer than 1 item) at validate (/.../mdb/node_modules/copy-webpack-plugin/node_modules/schema-utils/dist/validate.js:105:11) at new CopyPlugin (/.../mdb/node_modules/copy-webpack-plugin/dist/index.js:38:31) at Object. (/.../mdb/webpack/mdb/webpack.common.mdb.js:20:5) at Module._compile (internal/modules/cjs/loader.js:778:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10) at Module.load (internal/modules/cjs/loader.js:653:32) at tryModuleLoad (internal/modules/cjs/loader.js:593:12) at Function.Module._load (internal/modules/cjs/loader.js:585:3) at Module.require (internal/modules/cjs/loader.js:692:17) at require (internal/modules/cjs/helpers.js:25:18)


Grzegorz Bujański staff commented 2 years ago

Did you also follow the previous steps in this manual: https://github.com/mdbootstrap/mdb-webpack-starter#custom-version-of-mdb-ui-kit ?


Grzegorz Bujański staff answered 2 years ago


Sorry, but unfortunately we have no experience with parcel. We use the webpack. Here you will find a repo and instructions on how to build your own version: https://github.com/mdbootstrap/mdb-webpack-starter

After purchasing the package, you should receive an email with Gitlab access. If you can't find this e-mails, write to: contact@mdbootstrap.com


mdoma free answered 2 years ago


Hello

I tried to build a new min.js with parcel, but some errors appeared. Is the source for webdev or should the build work with parcel as well?

Another question, how can I access the pro repo on the git?

Thanks Miklos


Grzegorz Bujański staff answered 3 years ago


We use webpack and this plugin to merge all files into one: https://www.npmjs.com/package/webpack-merge-and-include-globally/v/2.1.8



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • ForumUser: Free
  • Premium support: No
  • Technology: MDB Standard
  • MDB Version: MDB5 3.5.1
  • Device: Desktop
  • Browser: Firefox
  • OS: Windows 10
  • Provided sample code: No
  • Provided link: No