Topic: TableEditor is not defined

Odhran priority asked 1 year ago


TableEditor plug does not work with MDB5, I get the error 'TableEditor is not defined'.

We have purchased the following packages but they don't seem to work together:

TABLE EDITOR PLUGIN (jQuery version[standard Bootstrap]) mdb-editor_4.8.11, MDB Standard Essential- mdb5-standard-ui-kit-pro-essential-3.9.0

Can you please advise on if they should work, or what we can do to get them to work?

I'm using the Async data code from the table editor examples.

I reference these CSS files:css/bootstrap.min.css,css/mdb.min.css,ss/addons/datatables.min.css,css/addons/table-editor.min.css

and these js files:js/jquery-3.4.1.min.js,js/popper.min.js,js/bootstrap.min.js,js/mdb.min.js,js/site.js,js/addons/datatables.min.js,js/addons/mdb-editor-es6.jsthanks.


Grzegorz Bujański staff answered 1 year ago


Unfortunately, MDB4 plugins are not compatible with MDB5 packages. We have created a new Table Editor that is compatible with MDB5: https://mdbootstrap.com/docs/standard/plugins/table-editor/


Odhran priority commented 1 year ago

That's the code I'm trying to use and it doesn't work?


Odhran priority commented 1 year ago

The version of MDB5 in downloads (MDB Standard Essential- mdb5-standard-ui-kit-pro-essential-3.9.0) doesn't have a Plugins folder. From other support questions, I see a lot of people are having the same issue of the Plugins folder being missing. Please advise on how we can access the plugins?


Grzegorz Bujański staff commented 1 year ago

MDB essential version does not contain plugins. You need MDB advanced version.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB Standard
  • MDB Version: MDB5 3.9.0
  • Device: laptop
  • Browser: Chrome
  • OS: Windows
  • Provided sample code: No
  • Provided link: No