Topic: Vue 3 + Vite + MDB Bootstrap5

THIAGO ALBERTO priority asked 7 months ago


Hey guys, Did anyone manage to use the mdb5 version with vue 3? I found the mdb5 version works better for me than the MDB Vue version. I installed a Vite version, then I installed MDB5, imported the files, and everything worked perfectly, but when using a component that has javascript, the component doesn't work. I don't know why but JS does not run or does not recognize. I'm going to put some code using a Toast, very simplex but it doesn't work.

Meu componente => enter image description here

The ones that have javascript and the plugins don't work. Someone by chance managed to get this to work.


Mikołaj Smoleński staff commented 7 months ago

Unfortunately we do not guarantee the correct integration of our Standard UI KIT with Vue. Integration can be done at your own risk, but to guarantee integration, we recommend using the dedicated MDB Vue UI KIT.

Keep coding,  Mikołaj from MDB



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Opened

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB Standard
  • MDB Version: MDB5 3.11.0
  • Device: pc
  • Browser: edge
  • OS: windows
  • Provided sample code: No
  • Provided link: No