I can`t import MdbWysiwygModule in app.module.ts


Topic: I can`t import MdbWysiwygModule in app.module.ts

MarioPalacios1986 asked 3 years ago

I have just bought the Wysiwyg plugin v.8.2.0 for Angular. I make all the installation steps in a already existing project and the installation was ok. (I follow the installation's documentation).

But when a try to make the import of the module MdbWysiwygModule, is simply not found.

Please someone help me. Thanks.


MarioPalacios1986 commented 3 years ago

I make the installation in a existing project with Angular Pro.


MarioPalacios1986 commented 3 years ago

this is the message:

WARNING in ./src/app/app.module.ts 77:16-32 "export 'MdbWysiwygModule' was not found in 'ng-uikit-pro-standard'

ERROR in src/app/app.module.ts(12,23): error TS2305: Module '"../../node_modules/ng-uikit-pro-standard/ng-uikit-pro-standard"' has no exported member 'MdbWysiwygModule'.


MarioPalacios1986 commented 3 years ago

And, when i run: "npm install" , this warnings show up:

npm WARN @angular/animations@8.2.0 requires a peer of @angular/core@8.2.0 but none is installed. You must install peer dependencies yourself.

npm WARN angular-bootstrap-md@8.2.0 requires a peer of @angular/common@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN angular-bootstrap-md@8.2.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN mdb-wysiwyg@8.2.0 requires a peer of @angular/common@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN mdb-wysiwyg@8.2.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN ng-uikit-pro-standard@8.1.1 requires a peer of @angular/common@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN ng-uikit-pro-standard@8.1.1 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.


MarioPalacios1986 commented 3 years ago

I installed the 2 dependancies needed to fix this WARN:

npm WARN mdb-wysiwyg@8.2.0 requires a peer of @angular/common@^8.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN mdb-wysiwyg@8.2.0 requires a peer of @angular/core@^8.0.0 but none is installed. You must install peer dependencies yourself.

So I run:

npm install @angular/common@^8.0.0 ---save

npm install @angular/core@^8.0.0 ---save

But the same problem persist.


I everybody. I Fix this issue:

First of all, in the "app.module.ts" the import need to be like this:

import { MdbWysiwygModule } from 'mdb-wysiwyg'

Second; i was working with Angular 7, so I run

npm update --all

and fix the peer dependancies. Now is the Wysiwyg plugin is working fine. Cheers.


Arkadiusz Idzikowski staff commented 3 years ago

Glad it works. Version 8 of the plugin is compatible with Angular 8 and can't be used with Angular 7. In case of any further problem with migration from v7 to v8, we prepared migration guide: https://mdbootstrap.com/docs/angular/getting-started/migration/


MarioPalacios1986 commented 3 years ago

Oh thanks, for me it was not necessary to follow all the steps in that documentation, but may be in the future.

Regards.


Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Resolved

Specification of the issue
  • User: Free
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: 8.1.1
  • Device: Web, Mobile
  • Browser: Safari, Chrome, Firefox
  • OS: OSX, Win, Linux, IOS, Android
  • Provided sample code: No
  • Provided link: No