Topic: Upgrade Project to Angular 8 and ng-uikit-pro-standard failed compilations

Jan Louw pro asked 3 years ago


Error at compile time - MDB v 7.5.3

ERROR in ./node_modules/ng-uikit-pro-standard/assets/scss/mdb.scss
Module build failed (from ./node_modules/mini-css-extract-plugin/dist/loader.js):
ModuleBuildError: Module build failed (from ./node_modules/sass-loader/lib/loader.js):
  & ul.stepper.horizontal .step-new-content,
 ^
      Top-level selectors may not contain the parent selector "&".
╷
332 │ ┌   & ul.stepper.horizontal .step-new-content,
333 │ │   & ul.stepper.horizontal .step-actions {
│ └────────────────────────────────────────^
╵
  node_modules/ng-uikit-pro-standard/assets/scss/addons-pro/_steppers.scss 332:3              @import
  stdin 120:9                                                                     root stylesheet
  in /home/node/db2sars/node_modules/ng-uikit-pro-standard/assets/scss/addons-pro/_steppers.scss (line 332, column 3)
at runLoaders (/home/node/db2sars/node_modules/webpack/lib/NormalModule.js:302:20)
at /home/node/db2sars/node_modules/loader-runner/lib/LoaderRunner.js:367:11
at /home/node/db2sars/node_modules/loader-runner/lib/LoaderRunner.js:233:18
at context.callback (/home/node/db2sars/node_modules/loader-runner/lib/LoaderRunner.js:111:13)
at render (/home/node/db2sars/node_modules/sass-loader/lib/loader.js:52:13)
at Function.$2 (/home/node/db2sars/node_modules/sass/sass.dart.js:24388:48)
at wO.$2 (/home/node/db2sars/node_modules/sass/sass.dart.js:15315:15)
at uT.vr (/home/node/db2sars/node_modules/sass/sass.dart.js:9046:42)
at uT.vq (/home/node/db2sars/node_modules/sass/sass.dart.js:9048:32)
at iA.uD (/home/node/db2sars/node_modules/sass/sass.dart.js:8396:46)
at us.$0 (/home/node/db2sars/node_modules/sass/sass.dart.js:8538:7)
at Object.eH (/home/node/db2sars/node_modules/sass/sass.dart.js:1512:80)
at ad.ba (/home/node/db2sars/node_modules/sass/sass.dart.js:8459:3)
at iO.ba (/home/node/db2sars/node_modules/sass/sass.dart.js:8389:25)
at iO.cv (/home/node/db2sars/node_modules/sass/sass.dart.js:8376:6)
at py.cv (/home/node/db2sars/node_modules/sass/sass.dart.js:8166:35)
ERROR in node_modules/ng-uikit-pro-standard/lib/free/navbars/links.component.d.ts(3,31): error TS2307: Cannot find module '@angular/core/src/metadata/lifecycle_hooks'.
node_modules/ng-uikit-pro-standard/lib/free/navbars/navlinks.component.d.ts(3,31): error TS2307: Cannot find module '@angular/core/src/metadata/lifecycle_hooks'.

Dikpal free answered 2 years ago


Hello guys, any news about ng-uikit-pro-standard support for angular 8 ?


Konrad Stępień staff commented 2 years ago

Hi @Dikpal,

If you need you can import ng-uikit-pro-standard in version 8 for your project.

Also, if you have issues in this version we will answer for your post.

But, at this time we update only version 9.

Do you also mean something specific?

Best, Konrad.


Etisalat_NRM free commented 2 years ago

How do we import ng-uikit-pro-standard in version 8 ?


Arkadiusz Idzikowski staff commented 2 years ago

We prepared migration guide for migrations from v7 to v8: https://mdbootstrap.com/docs/angular/getting-started/migration/#mdb8

You should also take a look at Angular official update guide: https://update.angular.io/#7.0:8.0


elemech premium answered 3 years ago


Same problem as OP .


Damian Gemza staff commented 3 years ago

As I said, we'll let you know, when this problem will be resolved. For now, MDB is not ready to use with Angular 8. Please downgrade to the Angular 7.


Damian Gemza staff answered 3 years ago


Guys,

We'll let you know when this fix will be delivered.

Best Regards,

Damian


elemech premium commented 3 years ago

July 1st according to your comment elsewhere.


Marcelo Gomes pro answered 3 years ago


I am also using the new Angular 8 in my design with the MDB Angular PRO... :( All my team is frozen waiting for this solution...


Damian Gemza staff answered 3 years ago


Dear @bitjuice

The MDB 8 should be released within the next month. But this date may change if there will be some unspecified, strange problems.

Best Regards,

Damian


bitjuice pro commented 3 years ago

Thanks for the information Damian

Marco


bitjuice pro answered 3 years ago


Hi Damian,

when do you think that MDB 8 will be released?

Thank

Marco


Damian Gemza staff answered 3 years ago


Dear @Louw

We didn't test our MDB Angular 7 against Angular 8, so it may not work correctly. For now, if it's possible, please use the Angular 7, because we have to upgrade MDB to version 8.

Best Regards,

Damian


Jan Louw pro commented 3 years ago

Dear Damian, I've reverted back to Angular7 and will wait for MDB Angular8 compatibility version. Thank you for your response on this. Regards



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Pro
  • Premium support: No
  • Technology: MDB Angular
  • MDB Version: 7.5.1
  • Device: Na
  • Browser: Na
  • OS: Linux
  • Provided sample code: No
  • Provided link: No