Topic: MDB Azure DevOps run build error

MarTechBH premium asked 1 year ago


Expected behavior

react-scripts build

Creating an optimized production build... Failed to compile.

./node_modules/mdb-react-ui-kit/dist/css/mdb.min.css
ParserError: Syntax Error at line: 1, column 26

npm ERR! code ELIFECYCLE npm
ERR! errno 1 npm
ERR! * build: react-scripts build npm
ERR! Exit status 1 npm
ERR! npm
ERR! Failed at the *
build script. npm
ERR! This is probably not a problem with npm.
There is likely additional logging output above.

Actual behavior
Build Success

Resources (screenshots, code snippets etc.) Azure DevOps

"dependencies": {
"@azure/msal-browser": "^2.16.1",
"@azure/msal-react": "^1.0.1",
"bootstrap": "^4.3.1",
"browserslist": "^4.16.8",
"chart.js": "^3.5.1",
"connected-react-router": "6.5.2",
"glob-parent": "^6.0.1",
"history": "4.10.1",
"jquery": "^3.5.1",
"mdb-react-ui-kit": "git+blank" rel="nofollow">https://oauth2:***@git.mdbootstrap.com/mdb/react/mdb5/prd/mdb5-react-ui-kit-pro-essential",
"mdbreact": "^5.1.0",
"merge": "^2.1.1",
"node-fetch": "^2.6.1",
"popper.js": "^1.16.0",
"query-string": "^7.0.1",
"react": "^17.0.2",
"react-dom": "^17.0.2",
"react-icons": "^4.2.0",
"react-modal": "^3.14.3",
"react-popper": "^2.2.5",
"react-redux": "7.1.1",
"react-router": "5.1.2",
"react-router-dom": "5.1.2",
"react-scripts": "^4.0.3",
"reactstrap": "8.1.1",
"redux": "4.0.4",
"redux-thunk": "2.3.0",
"svgo": "1.3.0",
"web-vitals": "^0.2.4"
}



Try to add this to package.json for now:

  "resolutions": {
    "postcss-custom-properties": "^9.1.1"
  },


Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Premium
  • Premium support: Yes
  • Technology: MDB React
  • MDB Version: MDB5 1.3.0
  • Device: -
  • Browser: -
  • OS: Windows
  • Provided sample code: Yes
  • Provided link: No