Topic: Not working with electron react boilerplate

Palak@tru free asked 3 years ago


I tried both the paid as well as the free version of MDB library in electron react boilerplate. It is working in other boilerplates like create-react-app but not in the former one.

Error :mdbreact.esm.js:918 Uncaught TypeError: Object(...) is not a function at Button (mdbreact.esm.js:918)


Aliaksandr Andrasiuk staff answered 3 years ago


Hi,

Unfortunately, we can't say what causes the problem and why because we have no experience with electron. We will learn more about electron in the future.

I tried to find something similar on the web and found this topic where one of the answers was :

using window.require instead of require is one possibility of avoiding the conflict between electron's and browserify's require function.

Maybe it will help.

Best regards.



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Free
  • Premium support: No
  • Technology: MDB React
  • MDB Version: 4.19.0
  • Device: MacBookAir
  • Browser: Chrome
  • OS: Mac
  • Provided sample code: No
  • Provided link: No