Topic: Do I need to do anything about this warning error when installing CLI?

IAA_73 priority asked 8 months ago


When installing mdb-cli

npm WARN deprecated core-js@2.6.12: core-js@<3.4 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.

I have no idea what to do with this.


Sebastian Kaczmarek staff commented 8 months ago

We'll have a look at this but for the time being, please just ignore that.


foys priority commented 7 months ago

I found topics from over a year ago stating this issue and it's still there. And because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js. it looks like something to resolve asap. Can't you just up the version in the package?


Sebastian Kaczmarek staff commented 7 months ago

@foys Currently, we are focusing on making the product stable and as intuitive as possible. Getting rid of the bugs and such warnings is a part of that process but it takes time. It's not always as easy as upping the version in package.json because we have a ton of features and we need to make sure that we are not breaking anything. MDB CLI is being used in a variety of environments and scenarios. This is why, as long as it doesn't break anything, we'd rather have a little warning during installation than break someone's CI/CD pipeline for instance. I hope that helps understand our point of view on that. If you have any other questions please add a new comment :)


foys priority commented 7 months ago

Hey Sebastian. Thanks for your reply. Sounds reasonable enough :)



Please insert min. 20 characters.

FREE CONSULTATION

Hire our experts to build a dedicated project. We'll analyze your business requirements, for free.

Status

Answered

Specification of the issue

  • User: Priority
  • Premium support: Yes
  • Technology: MDB Standard
  • MDB Version: MDB5 3.11.0
  • Device: pc
  • Browser: edge
  • OS: win 10
  • Provided sample code: No
  • Provided link: No