Sign in


Sign up


MDB Angular - Frequently Asked Questions

There are 2 ways to do it:

  1. You can download zip package and include it as a part of your app (i.e. into src/app/shared/mdb).
  2. You can install it using npm as a module (will be installed under node_modules folder).

You can find installation steps for both options here.

Sure it is! You will need an account at our git server (if are PRO user and don't have one please contact us via contact@mdbootstrap.com). Once you have an account simply follow our 5 min quick start.

Use following workaround:

add following into tsconfig.json file located in *root* folder

"include": ["node_modules/ng-mdb-pro/**/*.ts",  "src/**/*.ts"], 

(note: there is also tsconfig.app.json file inside src folder, however if you want to use it, path should be different)

"include": [ "**/*.ts", "../node_modules/ng-mdb-pro/index.ts" ]

Note! for MDB free package use following package name: node_modules/angular-bootstrap-md/index.ts

As a long term solution we will compile MDB to JS, currently all tasks related to that subject are performed at this branch. All help/contribution will be appreciated.

This issue was fixed in 4.3.7 release, please refer to either changelog or Alerts documentation.
In 4.3.7 we have excluded ToastService from Alerts as it has to be loaded separately as singleton. You can find more information on how to import it in either changelog or Alerts documentation
Since Angular 5 was released recently, still many 3rd party libraries or tools are not updated for the sake of compatibility. As a result, npm installer is warning that it is expecting version 4, but it wasn't found due to fact that you most probably are already using version 5.x. In most of the cases you can ignore this warning.
Currently MDB doesn't support RTL support. This is caused due to fact that Bootstrap doesn't support RTL itself.
If you see the following warnings, do not worry about them. This is not the fault of MDB itself, it is the fault of Bootstrap. Warnings indicate that certain features are marked as outdated and will be deleted in Bootstrap 5.
           
WARNING: The `text-hide()` mixin has been deprecated as of v4.1.0. It will be removed entirely in v5.
on line 10 of scss/bootstrap/mixins/_text-hide.scss, in mixin `text-hide`
from line 57 of scss/bootstrap/utilities/_text.scss
from line 14 of scss/bootstrap/_utilities.scss
from line 41 of stdin
           
       
That's common problem for our users. In case when you need to use some Bootstrap's Mixins in your components, please check this link: How to use media breakpoints